Problem Please Help
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    The Spirit Engine Forum Index // The Spirit Engine
View previous topic :: View next topic  
Author Message
ajk123
Human


Joined: 19 Dec 2007
Posts: 17

PostPosted: Tue Jan 01, 2008 7:29 pm    Post subject: Problem Please Help Reply with quote
Sad i have a slight problem, when i play spirit engine, after a certain amount of fighting and battling * same thing really lol* i encounter an error saying it needs to close i have downloaded the upto date version 1.04 but to no avail if anybody can help as it is ruining a really alround good game thanks. aj
Back to top
View user's profile Send private message ICQ Number
Hermit
Human


Joined: 01 Jan 2008
Posts: 18
Location: British Columbia, Canada

PostPosted: Tue Jan 01, 2008 9:42 pm    Post subject: Re Reply with quote
Hi AJ,

I'm having a similar problem with TSE. After about 20 minutes of straight battles, the game crashes suddenly, though, there is no notification to upgrade the game to 1.04 for me. Are you completely up-to-date with TSE? If not, here's a few links directly from the TSE1 site for you to download to patch your game to the newest version:

V.103 - 104:
http://www.thespiritengine.com/Files/TSEp103to104.exe

V.102 - 103:
http://www.thespiritengine.com/Files/TSEp102to103.exe

V.101 - 104:
http://www.thespiritengine.com/Files/TSEp101to104.exe

Copy and paste the links into your browser address bar. If you do have the latest version of the game, you'll probably be getting a crash glitch anyways. The best way to avoid this is to save every few battles (I suggest every 2 battle maps) and to quit the game and relaunch it again. It can be a hassle, but at least it fixes the problem.

I recall a post in which a user asked for a copy of TSE1 without any music implemented, this seemed to fix the crash problem. Perhaps you could ask Mark to give you a link to that copy, if he still has the file, I'd like to have a copy myself as well.

Hope this helps,
Hermit
Back to top
View user's profile Send private message ICQ Number
ajk123
Human


Joined: 19 Dec 2007
Posts: 17

PostPosted: Tue Jan 01, 2008 10:39 pm    Post subject: thanks my friend Reply with quote
thanks for that yes im currently upto date with tse thank mate, ile ask mark for a copy of the link ile see if i can get one aswell for you
Back to top
View user's profile Send private message ICQ Number
Hermit
Human


Joined: 01 Jan 2008
Posts: 18
Location: British Columbia, Canada

PostPosted: Wed Jan 02, 2008 1:29 am    Post subject: Reply with quote
Glad I helped Very Happy

You'll probably want to make a different thread specifically asking for that version of TSE. You'll likely not get a reply until tomorrow, since Mark usually only comes on in the morning.
Back to top
View user's profile Send private message ICQ Number
Mark Pay
Site Admin


Joined: 09 Aug 2006
Posts: 623
Location: Margate, UK

PostPosted: Wed Jan 02, 2008 9:40 am    Post subject: Reply with quote
Hi there. The version with the music removed can be found here:
www.thespiritengine.com/Files/TSEBuild0615musicstrip.exe

It sucks to lose the music. Sad The next best thing would be to download the OST from Josh's site at http://tse.syntesis.org/ and play it in the background.
Back to top
View user's profile Send private message Send e-mail ICQ Number
ajk123
Human


Joined: 19 Dec 2007
Posts: 17

PostPosted: Wed Jan 02, 2008 5:17 pm    Post subject: thankyou my friend a great help Reply with quote
thanks mark i really owe you one my friend i can now get back to your excellent game.. thanks again and happy new year to you Very Happy
Back to top
View user's profile Send private message ICQ Number
TwiTerror
Musical Maestro


Joined: 17 Aug 2006
Posts: 155

PostPosted: Wed Jan 02, 2008 7:03 pm    Post subject: Reply with quote
Hey guys.

I am entirely responsible for this bug, and I express my sincere apologies to you as you continue through this amazing game. Fortunately, TSE2 has a completely new audio engine that has been beta tested for over 10 months, so all of the troubles will be absent (until you guys find some new ones Razz).

~ Josh
Back to top
View user's profile Send private message
ajk123
Human


Joined: 19 Dec 2007
Posts: 17

PostPosted: Wed Jan 02, 2008 7:48 pm    Post subject: OH NO!! Reply with quote
AHHHH! Another Glitch in the Music Strip oh no!, i play through the game, and as i play with no music, the sound glitches and you have to move the mouse in order to continue the game i dont know why this game has so many problems, has anybody else encountered this problem??
Back to top
View user's profile Send private message ICQ Number
Hermit
Human


Joined: 01 Jan 2008
Posts: 18
Location: British Columbia, Canada

PostPosted: Wed Jan 02, 2008 8:13 pm    Post subject: re Reply with quote
Thanks for providing the music strip, Mark Very Happy

I've played most the game through without any crashes, wonderful Very Happy.
Back to top
View user's profile Send private message ICQ Number
TwiTerror
Musical Maestro


Joined: 17 Aug 2006
Posts: 155

PostPosted: Wed Jan 02, 2008 8:53 pm    Post subject: Reply with quote
I have no idea why the sound would stutter or cause problems, I was not involved in the design of the sound engine. That is all MMF stuff.
Back to top
View user's profile Send private message
Mark Pay
Site Admin


Joined: 09 Aug 2006
Posts: 623
Location: Margate, UK

PostPosted: Wed Jan 02, 2008 10:07 pm    Post subject: Reply with quote
Are you using Windows Vista ajk123? Also, did the sound stutter with the previous version of the game which had music?
Back to top
View user's profile Send private message Send e-mail ICQ Number
ajk123
Human


Joined: 19 Dec 2007
Posts: 17

PostPosted: Thu Jan 03, 2008 12:27 am    Post subject: no not vista!! lol Reply with quote
no mate im using the windows xp proffesional on my laptop, the problem is as follows:

everythings fine i kill the first wave after you start at the giants cradle, (fine)

i kill the next wave then it repeats the sounds of the dieing and gun firing constantly, then it stops, i move the mouse in the game and everything speeds up im like WOW! hang on! lol,

i have played upto 3o mins trying to solve the problem, seing if its my pc spec or sound card nothing everythings working fine, i just dont understand it, i hope there is a way to solve this because im anxious to complete it having downloaded this game 2 years ago lol, and am waiting in anticipation of your next venture, seen the clip on youtube of the fight sequence excellent graphics, excellent usage, excellent everything Very Happy, i just wish this game would work lol i solve one problem and another one crops up typical... AJ
Back to top
View user's profile Send private message ICQ Number
Hermit
Human


Joined: 01 Jan 2008
Posts: 18
Location: British Columbia, Canada

PostPosted: Thu Jan 03, 2008 2:44 am    Post subject: re Reply with quote
You could try reinstalling TSE, that may work Very Happy
Back to top
View user's profile Send private message ICQ Number
Mark Pay
Site Admin


Joined: 09 Aug 2006
Posts: 623
Location: Margate, UK

PostPosted: Thu Jan 03, 2008 5:24 pm    Post subject: Reply with quote
Hmmm. Well I'm glad it's not Vista, that would complicate things. As Josh said, the sound engine in MMF is unfortunately beyond our control.
I am currently looking at replacing the music plugin with a more up to date version and releasing a patch since I have some time free at the moment, but there is a lot to do for this. If it works I will rebuild the game in the current version of MMF 1.5 and this might help your sound stutter as well as the music related issues. I am sad to say that beyond that, I am not able to do much more about sound effect issues. I intend to buy a copy of MMF 2 this month, but I do not expect to be able to build either TSE 1 or 2 in it without creating a lot of new issues.

Could I confirm that you did not have this sound stutter in version 1.04 when you played it on the same computer?
Back to top
View user's profile Send private message Send e-mail ICQ Number
ajk123
Human


Joined: 19 Dec 2007
Posts: 17

PostPosted: Thu Jan 03, 2008 5:31 pm    Post subject: Reply with quote
hey ive had no problems so far ive been on it today everything seems to be working fine for the moment mark, ive played it on my pc and it doesnt work, the sound issues continue, but so far on my laptop its oky.. strange lol, i hope it continues to work fine... fingers crossed Confused
Back to top
View user's profile Send private message ICQ Number
Post new topic   Reply to topic    The Spirit Engine Forum Index // The Spirit Engine All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron // Icons in Part By: Travis Carden
Powered by phpBB © 2001, 2002 phpBB Group